Skip to Content
1

Unsupported encoding ISO-8859-1 for Package.settings":org.eclipse.wst.ws.service.policy.prefs' file

Feb 20, 2017 at 09:17 PM

1.1k

avatar image

I have created a SAPUI5 project in Eclipse but when I try to check it into I get the following errors:

Uploading files to repository... Unsupported encoding ISO-8859-1 for the 'LTC.IMSciences.".settings":org.eclipse.wst.ws.service.policy.prefs' file; only UTF-8 encoding is supported. Apply the quick fix to change the encoding settings. Unsupported encoding ISO-8859-1 for the 'LTC.IMSciences.".settings":org.eclipse.jst.j2ee.ejb.annotations.xdoclet.prefs' file; only UTF-8 encoding is supported. Apply the quick fix to change the encoding settings. Unsupported encoding ISO-8859-1 for the 'LTC.IMSciences.".settings":org.eclipse.jdt.core.prefs' file; only UTF-8 encoding is supported. Apply the quick fix to change the encoding settings. Unsupported encoding ISO-8859-1 for the 'LTC.IMSciences.".settings":org.eclipse.core.resources.prefs' file; only UTF-8 encoding is supported. Apply the quick fix to change the encoding settings.

I have Eclipse Neon with the SAP HANA tools running on a MAC,

I can't find where the incorrect value has been set to ISO-8859-1 so I can change it.

Under Eclipse->Preferences->General->Workspace I have the text file encoding as UTF-8.

I did look through the article - https://archive.sap.com/discussions/thread/3804956 - but it does not have the solution. It does point to the article - https://archive.sap.com/discussions/thread/3673580. But the value is already UTF-8.

Thanks for any help in advance.

Regards,

Jay

10 |10000 characters needed characters left characters exceeded

Thanks Jay - I was pulling my hair out with this problem, and you have really helped me out.

May good things come your way :-)

Mark

0

Thanks so much Jay, worked like a charm!

Cheers,

Glenn

0
Former Member

Thanks Jay

Helped me ,other suggested Preferences - > General -> workspace where I set UTF-8 but you suggested Java properties section uner General where the actual error when I changed encoding to UTF-8 as per JPEGS images you attached it made the erro go away Iam using Eclipse Neon 3.X

thanks

Rama

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Jay Malla Feb 20, 2017 at 10:14 PM
1

Actually i found the answer. I have created the images of where the default ISO-8859-1 encoding is set for the Java property files in Eclipse and where to change this. I hope this helps other people who might run into this issue.

eclipse-general-content-types-java-properties-file.jpg

eclipse-general-content-types-java-properties-file.jpg


Show 3 Share
10 |10000 characters needed characters left characters exceeded

Attaching the images...

eclipse-workspace-spelling.jpgeclipse-workspace-text-file-encoding.jpg

properties-for-project.jpg

0
Former Member

Hi Jay,

This setting Worked for me.

Thanks.

Prasad

1
Former Member

Thanks Jay! This fixed the issue.

Thanks,

Pratham

2