Skip to Content
1
Aug 16 at 01:14 PM

Deployed app not working - $metadata - File not found

432 Views

Hey guys,

i have been following this tutorial: https://developers.sap.com/group.dsag-cloud-dev-day-cf.html

I did every step and deployed the app to the btp.

I tested it after deployment and got the same result on the metadata:

After that i went to the HTML5 Applications like in the tutorial and found my managed app router.

There i clicked on it and and saw my tile

But when i click on it i get this error message:

In the F12 console it says:

GET fragebogenservice/$metadata - File not found sap.ui.model.odata.v4.lib._MetadataRequestor

And

The following error occurred while displaying routing target with name 'EigenfremdList': Error: File not found -

The app itself is working in the business application studio.

Also in the chapter "Deploy your application with access control" you adjust the mta.yaml file and add this section:

But after the deployment i went to the destinations in my BTP an saw, that no destination was created. Shouldn't it have been created automatically?

I thought this was what gave me the error, so i created it manually. But i still get the file not found screen.

Can anyone help?

Regards
Cemre

Attachments

unauthorized.png (5.6 kB)
tile.png (15.6 kB)
file-not-found.png (15.7 kB)
mta.png (10.7 kB)