Skip to Content
0

Cannot install server tools, installation sees as already installed

Feb 20, 2017 at 03:56 PM

237

avatar image

Hello,

One of our clients is running SAP B1 9.1 PL11. They had an issue with their SLD so we decided to uninstall the server tools and reinstall it again.

After we uninstalled the server tools, we deleted the installation folder and the temp files and then restarted the server. Tried to reinstall server tools but the installation still thinks that the server tools is installed yet it was uninstalled.

During the reinstallation of the server tools, the window below pops up. The SLD Database was removed during uninstall of Server tools. Kindly assist.

We also tried to uninstall ALL components of SAP B1 to perform a fresh installation but as you can see during the fresh installation server tools is already installed

installation.png (52.5 kB)
server-tools.png (144.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Pascale Khayeri Mwavaga Feb 23, 2017 at 06:15 AM
1

I tried to delete all SAP folders in the registry (Start > Run > regedit):

1. HKEY_CURRENT_USER > Software > SAP (delete folder)

2. HKEY_LOCAL_MACHINE > SOFTWARE > SAP (delete folder)

3. HKEY_USERS > .DEFAULT > Software > SAP (delete folder)

Unfortunately, this also did not work.

The culprit was: HKEY_LOCAL_MACHINE > SOFTWARE > Wow6432Node > SAP (delete folder)

Share
10 |10000 characters needed characters left characters exceeded