Skip to Content
0

How to integrate ESRI GIS with agentry android client 7.14.0

Feb 20, 2017 at 02:55 PM

146

avatar image

Dear expert

I have successfully build an agentry client for Android including GIS and 3D VE last year. I am trying now to upgrade my agentry client from level 7.0.5 to 7.14.0.37, but I do not get the map loaded with new Android. (see log.txt and gis.png for more details)

I am using the following components to build the android app. Thanks for help. Regards.

FYI: I succeed to get GIS working with the iOS client 7.14.0 and EAM SDK level 2.1

FYI: I was also getting the JSON exception with Android client 7.13.5 but map was loaded

(see esri70135androidlog.txt )

*******************************************************

Code Levels:

Eclipse => Neon

Agentry SDK => SMPAgentryClientFramework-Android-70.14.0

SAP EAM and service mobile app SDK 2.1.0 Android ==> 51051404_1.ZIP

SAP GIS SDK => ArcGIS 10.2.6-2 => arcgis-android-sdk-v10.2.6-2.zip

Instructions => SAP EAM and service mobile app SDK 2.1

gis.png (34.8 kB)
log.txt (4.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Didier Decroos Mar 14, 2017 at 04:29 PM
0

I got it working with

Code Levels:

Eclipse => Neon

Agentry SDK => SMPAgentryClientFramework-Android-70.14.7

SAP EAM and service mobile app SDK 2.1.0 Android ==> 51051404_1.ZIP

SAP GIS SDK => ArcGIS 10.2.6-2 => arcgis-android-sdk-v10.2.6-2.zip

Instructions => SAP EAM and service mobile app SDK 2.1

Share
10 |10000 characters needed characters left characters exceeded