Skip to Content
avatar image
Former Member

Products are not getting created in hybris marketing cloud

Hello Team,

We are not able to transfer product and product category from hybris commerce. We are trying to call the OData service from Data Hub and to transfer the product from hybris commerce to hybris marketing.

Thanks and Regards

Shanto Aloor

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Mar 17, 2017 at 01:06 AM

    Hello Shanto,

    difficult to answer based on the few details provided. I can only suggest the following points to check:

    • The products (and their categories) are extracted for a specific catalog version. Out of the box, our impex configures the extraction cronjob for electronic product catalog, version staged. So if this catalog is not in used, you might want to change this parameter to a valid catalog version in your platform.
    • If you don't make a database change to the products, nothing will be sent. So as a test, select a product, change a value (e.g. description) and trigger the cronjob again. Y2Y sync framework will flag objects to be sent only when flagged as newly created or modified. For an initial load, you can implement a simple cronjob to mark all existing products as ready for sending.
    • Finally, please check the local.properties file of the Data Hub. There you should check the URL of the Hybris Marketing system, the technical user and password used for the OData web service call.
    • If everything above is fine, the last possibility is the authorization profile assigned to the technical user in Hybris Marketing. This is specifically important in the case of yMKT cloud, as more authorizations are required.
    I hope this helps.Emmanuel
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 20, 2017 at 02:04 PM

    We resolved this by installing the latest patch of yCOMM 6.2

    Add comment
    10|10000 characters needed characters exceeded