Skip to Content
avatar image
Former Member

Attachments list is not visible on device

Hi Experts,

We have implemented SAP Work Manager 6.4 with Customer Service 2.3 on SMP 3.0.12.2.

When we attach the documents to work orders from application and do transmit the attachments will be synced to back-end , but on device we see the status as on device as shown in the below screen shot.

but the our requirement is we want the download icon to be displayed as shown in the below screen shot.

For Notification everything is working as required (we are able to see the download icon of the attachments uploaded form the device after delta sync)

i have maintain the document type as BDS for work order and for notifications it is DMS.

we had changed the document type of work orders to DMS and tried but still it dint work.

can you please help to resolve this issue.

Thanks

Madhukar G

capture.png (26.5 kB)
captur3.png (5.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Sep 12, 2017 at 03:11 PM

    As I understand your scenario.

    1. Work Orders are downloaded to the device
    2. Users add attachments to the workorder
    3. Users transmit to send the attachments to the backend
    4. The Work order remains on the device and the attachments are still listed showing a status of On Device

    My question is why do you not want it to show On Device. That is the correct status for the attachment you added to the work order. If you reassigned the work order to another user when it then downloaded to the device the first time the attachments would show the download indicator until the user fetched the document from the backend. Then they will show as On Device indicating they have been downloaded and are available for viewing. This is how I would expect this to function.

    Can you clarify?

    --Bill

    Add comment
    10|10000 characters needed characters exceeded