Skip to Content
0
Jun 08 at 05:33 PM

OpenSap - Preparing your ABAP development environment

184 Views Last edit Jun 08 at 06:04 PM 2 rev

Hello Experts,

I am trying to set up development environment as per steps mentioned in link below link

https://github.com/SAP-samples/fiori-elements-opensap/blob/main/week1/unit4.md.

see below steps in picture

after step 5 Its giving below error's.

Cannot complete the install because one or more required items could not be found. Software being installed: ABAP Connectivity And Integration Development Tools (Developer Edition) 1.137.0 (com.sap.adt.pitools.tlf.devedition.feature.group 1.137.0) 

Missing requirement: ABAP Connectivity and Integration UI 1.137.0 (com.sap.mts.aci.ui 1.137.0) requires 'osgi.bundle; org.eclipse.ui [3.118.100,4.0.0)' but it could not be found Cannot satisfy dependency: 

From: Enterprise Service Development Tools in ABAP 1.137.0 (com.sap.adt.pitools.feature.group 1.137.0) To: org.eclipse.equinox.p2.iu; com.sap.mts.aci.ui [1.137.0,1.137.0] Cannot satisfy dependency: From: ABAP Connectivity And Integration Development Tools (Developer Edition) 1.137.0 (com.sap.adt.pitools.tlf.devedition.feature.group 1.137.0) 

To: org.eclipse.equinox.p2.iu; com.sap.adt.pitools.tlf.feature.group [1.137.0,1.137.0] Cannot satisfy dependency: From: ABAP Connectivity and Integration Development Tools 1.137.0 (com.sap.adt.pitools.tlf.feature.group 1.137.0) To: org.eclipse.equinox.p2.iu; com.sap.adt.pitools.feature.group [1.137.0,1.137.0]

Cannot complete the install because one or more required items could not be found. Software being installed: BPC Embedded Planning (Developer Edition) 1.23.16 (com.sap.bw.feature.bpcplanning.devedition.feature.group 1.23.16) Missing requirement: samc Model 1.76.0 (com.sap.adt.conn.amc 1.76.0) requires 'osgi.bundle; org.eclipse.core.runtime [3.20.0,4.0.0)' but it could not be found Cannot satisfy dependency: From: ABAP Connectivity 1.76.0 (com.sap.adt.conn.feature.group 1.76.0) To: org.eclipse.equinox.p2.iu; com.sap.adt.conn.amc [1.76.0,1.76.0] Cannot satisfy dependency: From: ABAP Core Development Tools (Developer Edition) 3.18.1 (com.sap.adt.core.devedition.feature.group 3.18.1) To: org.eclipse.equinox.p2.iu; com.sap.adt.core.feature.group [3.18.1,3.18.1] Cannot satisfy dependency: From: ABAP Core Development Tools 3.18.1 (com.sap.adt.core.feature.group 3.18.1) To: org.eclipse.equinox.p2.iu; com.sap.adt.conn.feature.group [1.76.0,1.76.0] Cannot satisfy dependency: From: BPC Embedded Planning (Developer Edition) 1.23.16 (com.sap.bw.feature.bpcplanning.devedition.feature.group 1.23.16) To: org.eclipse.equinox.p2.iu; com.sap.adt.core.devedition.feature.group 0.0.0

Appreciate if someone could help here.

Thanks

RD

Attachments

procedure.png (64.2 kB)