Skip to Content
avatar image
Former Member

SAP Theme Designer caching issue

Hi,

I am having question on Theme Designer caching.

Built a custom UI5 app & built custom theme using THEME_DESIGNER tcode.

Am calling this themed app by having absolute URL of app appended with ?sap-theme complete value(i got this in THEME_TOOL info of theme) having some random cache value at end.

  • ØWhen I run theme with above method, all looks good and on the first run theme is not cached(this is ok) and on second run I can see theme is cached and significantly improving the load time
  • ØIf I make some change in theme, after building it I can see a different cache value. Now here is the problem. On using the same old URL from above step which is saved in my favorites, I am not able to see the new changes(because of the difference in cache value)
  • ØIf I don’t give any cache parameter at end of URL, everything works fine. Problem is the theme is not getting cached on local machine and thus resulting a high load time.
  • ØOn giving new cache value at end of URL, I ca see new changes

How can I solve the caching issue. Has anyone faced the similar issue?

Am having below configs for my system:

UI Theme Designer

Version:1.16.10

Engine Version: 1.16.19

SAPUI5 Core Version:1.38.14

Thanks,

Vivek

Add comment
10|10000 characters needed characters exceeded

  • Former Member Former Member

    Hi Masa,

    I tried clearing the cache and used the Execution mode and it did not help me in clearing the cache.

    In my URL am using ?sap-theme till end of cache value and even after clearing cache I see the old data( I made some changes to theme and build it which has generated new cache value, however I am still using the old cache value as it was saved in my favorites).

    By any chance have you faced the similar issue. I need to have my theme cache and therefore can’t remove cache keyword from my URL.

    Thanks,

    Vivek

  • Hi Vivek,

    About "/~cache-CACHETOKEN" is described in the note https://launchpad.support.sap.com/#/notes/2043817/E.

    Regards,

    Masa / SAP Technology RIG

  • Former Member Masayuki Sekihara

    Thank you Masa for the link.

    I used ~cache-1 in my old ECC system and there it worked. But with new system, this parameter is not working as expected. I tried clear the cache as suggested(not the user profile) and no success. Is there anyother cache i need to clear.

    Thanks,

    Vivek

  • Get RSS Feed

0 Answers