Skip to Content
0
May 17, 2021 at 10:12 PM

crystal reports doesn't work IIS 10 non standard web root

518 Views Last edit May 18, 2021 at 05:53 PM 2 rev

This is driving me nuts. I have CR Runtime 32 and 64 bit installed on Windows 2019 sever (IIS 10) Visual Studio is installed along with CR for Visual Studio. I just have a blank nothing report, just to see if I can get things working. When I run it in debug (through IIS Express / Visual Studio "run" option) I see the blank report. When I load it directly from IIS I get the following:

Retrieving the COM class factory for component with CLSID {F734A321-8381-4FFD-A614-139E8906DC83} failed due to the following error: 8007007f The specified procedure could not be found. (Exception from HRESULT: 0x8007007F)

The wwwroot is NOT in the standard location, so I'm guessing that has something to do with it. However I keep finding things that seem like they might help and they don't.

I have copied over the crystalreportsviewers13 folder to my web app. (and I see it getting referenced when I do the VS run)

I have added the resourceURi value to the web.config

I have tried enabling 32bit apps on the app pool.

I am not sure why it will run and show a report when I run it on the server via Visual Studio and NOT work being served up directly from IIS. This seriously should be install and work. I am getting very disappointed.