Skip to Content
author's profile photo Former Member
Former Member

Still having issues with custom ejb :-(

I now see this in the logviewer -

Transaction rolled back for meesage 44564b42-a8be-05fd-e100-0000a3f331a4(INBOUND) due to: local bean not found: localejbs/sap.com/com.gy.jms.RemoveSpecialCharacters/RemoveCharactersBean

However, I do see under Services => EJB Container =>sap.com/com.gy.jms.RemoveSpecialCharacters => RemoveCharactersBeans

deployed successfully

In my adapter, I have the following settings

1

Module Name -localejbs/sap.com/com.gy.jms.RemoveSpecialCharacters/RemoveCharactersBean

Local Enterprise Bean

Module Key - create

Module config

Module key - create

Parameter name - parameter

Parameter value - value

From this blog,/people/alessandro.guarneri/blog/2006/03/16/xi-mapping-module-for-afw

Hint. Remember to set up also the JNDI name in your ejb-j2ee-engine.xml, which must match the name you'll use to invoke the module from a communication channel.

I added JNDI name as RemoveCharactersBean

Any more ideas?

Appreciate any thoughts on this.

Thank you

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on May 02, 2006 at 10:05 PM

    Hi,

    >>>-localejbs/sap.com/com.gy.jms.RemoveSpecialCharacters/RemoveCharactersBean

    you can see the path in deploy service in VA

    if you add JNDI name you can try

    localejbs/RemoveCharactersBean

    but just have a look in VA as I said and you all know for sure or ask any java colleague to show you

    Regards,

    michal

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 02, 2006 at 10:11 PM

    Just check the Spelling/Typo errors of the Module Created. Also check for , is the module is deployed correctly without any errors(While deploying)

    Thanks,

    Moorthy

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 03, 2006 at 04:53 AM

    If you added JNDI name as

    >> I added JNDI name as RemoveCharactersBean

    i.e. if you open ejb-j2ee-engine.xml in a text editor you should see following entry in it

    <jndi-name>RemoveCharactersBean</jndi-name>

    In this case you can specify the Module name as

    localejbs/RemoveCharactersBean

    You can check the same in JNDI registry in Visual administrator.

    Rgds,

    Amol

    Add a comment
    10|10000 characters needed characters exceeded

    • > 2006-05-03 10:38:47 Error Exception caught by adapter

      > framework: <b>Exception thrown in method process</b>. The

      > transaction is marked for rollback.

      It seems that your bean is used, but inside your been an exception is thrown.

      You should add a text to the exception to see what happend in your bean.

      Regards

      Stefan

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.