Skip to Content
avatar image
Former Member

Event geeting triggered but WI doesnt proceed

Hi All ,

In my workflow , I have have a step which waits for the event 'TRIP.CHANGED' . And when the event is occured next step will be executed .

I have came accross a strange situation wherein the even is getting triggered but the next step is not executed . The workflow is still in the <b>WAIT</b> state .

Previously it was working but now its not working .

What could be the reason ?? Any thoughts ...

Thanks ,

Sonu M.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    May 04, 2006 at 09:15 AM

    Hi Sonu,

    You can go to transaction swu0 wherein if you give your business object and the event you can see your particular workflow is linked or not.

    If it is linked that means it will show you a green light if not it will give you a red light.

    If it has a green light it is linked successfuly if not plz chek the bindings.

    Else if this all thing is working you might have done some other changes which hasnt reflected so go to transaction swu_obuf and sycronize it.(it might work)

    I had the same problem in my workflow , but i changed that wait for event condition and did some other check,so now it is working.You can also possibly change that condition and check some other condition.

    Regards,

    Prajakta.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 02, 2006 at 01:24 PM

    As you mentioned in the message that previously I was working but now it is not working.

    Did you do any changes and after that it stops working ?

    OR some thing else. Please let us know.

    Regards

    Aman

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Sorry guyz ,

      Sorry for bithering you . Mistakenly there was error in the code . The object key was going as '000000000' thats why the event wasnt getting triggered .

      But anyways your answers were really helpful ..

      Thanks again ,

      Sonu M.

  • avatar image
    Former Member
    May 02, 2006 at 01:14 PM

    Hi sonu,

    Are you sure that the required Event got triggered. May be you can test the same by switching ON the EVENT TRACE.

    Try it and let us know if correct event is triggered.

    Regards,

    <i><b>Raja Sekhar</b></i>

    Add comment
    10|10000 characters needed characters exceeded