Skip to Content

#ABAP_Trial Docker container IP not reached

#ABAP_Trial

Hello experts, I am facing a issue with setting up GUI configuration.

I followed the below tutorial to set up ABAP platform on my WINDOWS OS.

SAP ABAP Platform 1909 Developer Edition: Wrapup&Tips of Installation on Windows 10 | SAP Blogs

Docker installed, image extracted, container successfully runs. On the final step, I am facing a issue with

setting up GUI configuration. I get an error saying the connection is broken.

As you can see from the attached images, docker containers are working fine and port 3200 are published.

As instructed in the blog, I run the below command so that 3200 can be published.

"docker run --stop-timeout 3600 -i --name a4h -h vhcala4hci -p 3200:3200 -p 3300:3300 -p 8443:8443 -p 30213:30213 -p 50000:50000 -p 50001:50001 store/saplabs/abaptrial:1909 -skip-limits-check".

The problem is that "localhost" is not reached somehow, can anyone please tell me what is wrong? I am so close to the finish line!

(Tried to ping 127.0.0.1 and it works. Log attached.)

Cheers.

dev-disp.txtdev-ms.txtdev-w0.txt

guiconfig.png (24.4 kB)
errorgui.png (11.8 kB)
pinglog.png (12.1 kB)
dev-disp.txt (32.0 kB)
dev-ms.txt (2.8 kB)
dev-w0.txt (32.4 kB)
Add a comment
10|10000 characters needed characters exceeded

  • Hi Robert, really appreciate your help.

    The traces are attached so please check them out.

    Today I run the abap image with "--network host" paramter but ended in error so that log might be in there, After the error, I run the image properly again with the below command and like before, the container is running and the 3200 port is open the same way.

    PS: I somehow could not attach the files on this comment so I added them on my original post above in the below file names.

    dev_disp.txt, dev_ms.txt, dev_w0.txt

  • Hi Fredreic

    I run in my windows command. In the /etc/hosts I have put the below lines but sill the same error on the SAP GUI.

    127.0.0.1 localhost

    127.0.0.1 vhcala4hci

    Regarding the 0.0.0.0 vs 127.0.0.1, according to the below blog,

    0.0.0.0 is the defualt IP and if you do not specify the IP when using "docker run".

    Docker Port Binding explained | Better Programming

    But yes, maybe I should specify 127.0.0.1 in the "docker run" command and see if it works....

    "docker run --stop-timeout 3600 -i --name a4h -h vhcala4hci -p 127.0.0.1:3200:3200"

  • Hi Aocheng,

    seems you have done everything correct. Could you please upload some trace files here. The command to copy them to c:\temp is:

    docker cp a4h:/usr/sap/A4H/D00/work/dev_w0 c:\temp
    docker cp a4h:/usr/sap/A4H/D00/work/dev_disp c:\temp
    docker cp a4h:/usr/sap/A4H/ASCS01/work/dev_ms c:\temp

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on 5 days ago

    Hi Aocheng,

    you didn't share details about your exact hardware but after successful start the SAP work processes are dying with "Out of memory".

    from dev_w0:

    C  SQLERRTEXT : cannot allocate enough memory: Out of memory on query fetch
    ...
    A  P4: cannot allocate enough memory: Out of memory on query fetch

    Looks like you need some more RAM.

    I know, ABAP on HANA 1909 is cool and Andrea Borgia has recommended 1909, but you need the resources for this.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Aocheng Yang,

      yes 16 GB should be fine, but this is for the Docker alone. Plus the needed for Windows i guess the bare minimum will be 24 GB. In WSL2 you have not precise control over the allocated to Docker resources, but 16 for Windows and 1909 is not enough, sorry.

      Powerful CPU is nice to have although not essential in this case.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.