Skip to Content
avatar image
Former Member

web dynpro preview: NoSuchMethodError

Hello,

I am trying to deploy certain Web Dynpros contained in a portal business package for ESS (ess, pcui_gp). The System I am using is a Sneak Preview Java WAS 6.40, EP6.0, SP16. The deployment process as such seems to have worked correctly as the WD Content Admin shows me a complete list of all the packages under 'Deployed Content -> sap.com' with status 'green'.

However am facing the following problem when trying to run the preview of a package, say 'sap.com/pcui_gp~xssutils':

...
The initial exception that caused the request to fail, was:

java.lang.NoSuchMethodError:
 com.sap.tc.webdynpro.progmodel.context.Context.createNode(Ljava/lang/String;Ljava/lang/Class;
ZZZZZZLjava/lang/String;...)
    at com.sap.pcuigp.xssutils.ccxss.wdp.InternalCcXss.<init>(InternalCcXss.java:41)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)...

Unfortunately I am not yet familiar with Web Dynpro development, but I read that NoSuchMethod errors are usually due to version mismatchs. However the two packages in question - ess11p_4 and pcui_gp010p_1 - are the newest available and according to note 761266 they should fit to J2EE stacks with SP16 ?!

It'd be great if someone could share some insights on this.

Regards,

Sebastian

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    May 01, 2006 at 04:18 PM

    Please check again the exact versions (SP numbers), I would bet there is some version mismatch.

    Armin

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 02, 2006 at 06:35 AM

    Hi Armin,

    thanks for your quick answer. I don't really know how to render the problem more precisely though. I newly installed the Sneak Preview Java WAS 6.40+EP.60, SP16; the output of SystemInfo is:

    sap.com SAP-JEE 6.40 SP16 (1000.6.40.16.0.20060221071018) SAP AG 20060424092402

    sap.com SAP-JEECOR 6.40 SP16 (1000.6.40.16.0.20060221070818) SAP AG 20060424085421

    sap.com ADS_SAP 1.00 SP16 (1000.1.00.16.0.20060203041227) SAP AG 20060424083315

    sap.com ADS_SAPOFF 1.00 SP16 (1000.1.00.16.0.20060203041228) SAP AG 20060424081835

    sap.com SAP_DEVINF 6.40 SP16 (1000.6.40.16.0.20060209061538) SAP AG 20060424085452

    sap.com SAP_JTECHF 6.40 SP16 (1000.6.40.16.0.20060221071156) SAP AG 20060424085637

    sap.com SAP_JTECHS 6.40 SP16 (1000.6.40.16.0.20060221071338) SAP AG 20060424092300

    sap.com KM-KW_JIKS 1.00 SP16 (1000.1.00.16.0.20060202152157) SAP AG 20060424085058

    sap.com BP_ERP4ESS 60.2 SPnull (1000.60.2..0.20041012014145) SAP AG 20060425095628

    sap.com LM-TOOLS 6.40 SP16 (1000.6.40.16.0.20060201044724) MAIN_APPL63VA_C 20060424091000

    com.sap pdk-content 630 SP1 (1000.630.0.1.0.20051130181343) SAP AG 20060424090924

    sap.com SAPDEVINFF 6.40 SP16 (1000.6.40.16.0.20060209061643) SAP AG 20060424090638

    sap.com BI_MMR 350 SP16 (1000.350.0.16.0.20060203073250) SAP AG 20060424090828

    sap.com BI_UDI 350 SP9 (1000.350.0.9.0.20041025073430) SAP AG 20060424084234

    sap.com NWMADMIN 6.40 SP16 (1000.6.40.16.0.20060202120450) MAIN_APPL63VA_C 20060424090113

    The sca in question are ESS11P_4-10002965.sca and PCUIGP011_0-20000568.sca which according to note 761266 require SAP J2EE 6.40 SP15 + SAP ECC5.0 SP09 (min backend). I thought I met these requirements, but I am not sure anymore.

    Can you tell me what (type of) information you need and how one systematically gets to this?

    Regards,

    Sebastian

    Add comment
    10|10000 characters needed characters exceeded