Skip to Content
0
Feb 28, 2021 at 04:12 PM

Enhancement not getting called in production system

89 Views

Hello.

We have done previous enhancement implementation in transaction FPCI, subroutine create_file_body. Previously it used to refer custom table 1 and amend additional data in information file body sent to collection agency. This is working fine in production system.

Recently, we added few lines of code to the same enhancement which adds another line to the body of the file. This time we are referring to custom table 2 for populating appropriate details in file. This is working fine in dev and test system.

However when the transports were pushed to production environment, new lines of code in enhancement does not seem to be getting executed while running FPCI in batch mode. We tried to debug for one sample account in production and there the new lines of code in enhancement were called and an additional line was present in file. We have tried to regenerate the enhancement, include of FPCI, FPCI package, custom package, update navigation index etc. However nothing seems to work here.

One point to note is - our code does not refer any standard table or wait for some action to finish before proceeding. It always gets triggered at end of create_file_body subroutine after all standard receivable updates like payment, reversal etc have finished.

Please suggest if we are missing anything here.

Thanks, Prajyot.