Skip to Content
0
Feb 26, 2021 at 04:22 PM

Model 347 report issues

71 Views Last edit Mar 01, 2021 at 08:35 AM 7 rev

Hello all,

for one of our customer localized in spain, we need to manage the legal Tax Report(model 347).

The report runs and display tax data as expected.

Though, we are having issues with inconsinstency of this data.

The problem we're having is explained below and I also attached some screenshots of the output so that you can understand better what's our problem.

As I said above, we're having problem with consistency of the output of the report and to be more precise the field Business Partner Tax ID is not always showing/filled.

I noticed that this problem occurs only when I do not specify a range of documents to be reported, that is, the input parameter Document Number is empty.

Here's images of my selection screen:

Note: The first 5 input are in italian, here is the translation in order from top to bottom:

Company Code, Document Number, Fiscal Year, Posting Data, Reference Number.

Now, if I run the report with these inputs, all documents of year 2020 will be reported to the output list and the problem comes here.

Some document, such as the last two displayed in the screenshot below, have their Business Partner Tax ID field empty.

If we take a look at the data associated with the given Partner ID by using transaction code BP, we will see that the Tax ID exists and so there is no reason the report wouldn't fill that out.

As you can see, the Tax ID is there.

Now, the kind of strange thing that happens with this report is when I make a selection of specific Document Numbers.

The input is pretty much the same as before. The only thing I'm changing is the selection of Document Numbers.

In this case I'm requesting to report only document number 2010000044.

The output of this report is the one below:

We tried looking for Sap Notes that are relevant to this report(transaction code FIES_M347, program/report RPFIES_M347) and here's the one I found interesting: 2122879, 2383726.

We tried implementing sap-note 2383726, but it cannot be implemented on our system.

I've tried debugging the report to see if there's something wrong with the code, but I couldn't find anything that could cause this problem.

So, in conclusion, could this be an issue that's not been reported yet?

Attachments

correct-output.png (11.0 kB)
input-1.png (7.8 kB)
input-2.png (28.1 kB)
input-3.png (28.7 kB)
bp.png (64.1 kB)
input-4.png (9.0 kB)