/scripts/ahub.form.attachments.js
0

XSLT Error in PO 7.5 SP04 Dynamic Configuration

Feb 17, 2017 at 01:01 PM

82

avatar image
Former Member

Hi All,


I checked all the other questions here in the forum, but none of the provided answers was working for me.

We have a PO 7.5 SP 04

My XSLT looks like this:

<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet version="2.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:fn="http://www.w3.org/2005/xpath-functions" xmlns:map="java:java.util.Map" xmlns:dyn="java:com.sap.aii.mapping.api.DynamicConfiguration" xmlns:key="java:com.sap.aii.mapping.api.DynamicConfigurationKey">
<xsl:output method="xml" version="1.0" encoding="UTF-8" indent="yes"/>
<xsl:param name="inputparam"/>
<xsl:variable name="delimiter" select="'_'"/>
<xsl:variable name="dynamic-conf" select="map:get($inputparam, 'DynamicConfiguration')"/>
ariba.com:xi:OnDemand:Invoice','SystemID')"/>
<xsl:variable name="receiverName" select="dyn:get($dynamic-conf, $dynamic-key)"/>
<xsl:variable name="prefix" select="concat($receiverName,'',$delimiter)"/>
<xsl:template match="@*|node()">
<xsl:copy>
<xsl:apply-templates select="@*|node()"/>
</xsl:copy>
</xsl:template>
<xsl:template match="node()[starts-with(text(),$prefix)]">
<xsl:copy>
<xsl:value-of select="substring-after(text(),$prefix)"/>
</xsl:copy>
</xsl:template>
<xsl:template match="@*[starts-with(text(), $prefix)]">
<xsl:attribute name="{name()}"><xsl:value-of select="substring-after(.,$prefix)"/></xsl:attribute>
</xsl:template>
</xsl:stylesheet>

This XSLT was working in my old PI system PI 7.31, but not anymore in PO 7.5

I tried my setup with both options "Use XML ToolKit" and without "Use XML Toolkit"

Both setups end in the same error below.

xslt-error-prefix.jpg

Do you have any idea how to resolve this problem?


Thanks

Florian

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Manoj K Feb 17, 2017 at 01:25 PM
0

Florian,

To use XSLT 2.0 you need to set parameter in NWA .

https://blogs.sap.com/2014/10/14/how-to-import-and-use-xslt-20-mappings-in-sap-pipo/

Br,

Manoj

Share
10 |10000 characters needed characters left characters exceeded
Skip to Content