Skip to Content

Idoc Invoice without Delimiter " ' " after BIC conversion

Hi,

I sent an Invoice Idoc to a customer, but he isn't able to convert und process the data. As far as I know it is a problem of Segment separation. There are not ' in this message at the end of any segment. How can I force BIC to generate these separators ? Thanks in advance for any advice.

Torsten

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on May 03, 2006 at 05:06 PM

    Hi,

    you will need to use the parameter "destDelimiter".

    Set this in the communication channel. If you want to set up different delimiters for each trading partner, you will need to replicate the communication channel one for each trading partner.

    destDelimiter

    Sets the destination Delimiter. You must use a String with the length of 6 characters.

    The order of the delimiter is as follows:

    subfield, field, decimal, quoting, fieldgroup, segment

    Also you have the possibility to change the delimiters directly in your 1:1 X2E mapping in the bic designer. For this you have to open the mapping and at the destination options you set the flag and then you can change the settings at setDestinationDelimiters.

    Hope i could help

    ilka

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 27, 2006 at 09:54 AM

    Hi Torsten,

    Is it that you want ' to come in some fields ?

    Maybe you can handle that in your mapping itself.

    Can you elaborate more on the requirement.

    ShaBZ

    Add a comment
    10|10000 characters needed characters exceeded

    • Can you just explain the structure of the XML and where you need the ' to come.

      If you need it to come after the last field of the segment then add a constant ' after the particular area or field.

      ie if you need to differentiate between various segments, u can add the ' after the last field of each segment.

  • Posted on Apr 27, 2006 at 10:00 AM

    use enclosuresign ..option in file CC..it will allow you to ignore special characters...Iam assuming u want to supress ' when it comes within ""..!

    if yes check the content conversion parameters in this blog where i supress , when it comes within ""

    /people/sravya.talanki2/blog/2005/11/29/night-mare-processing-huge-files-in-sap-xi

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.