Skip to Content
avatar image
Former Member

soap receiver - owerwrite default http header fields

Hi,

I'm using the soap receiver adapter in nosoap mode.

How can I owerwrite the default settings for the header fields in the http request?

The soap adapter will automatically set content-type = application/xml.

I would like for example set "text/xml".

Thanks,

Bela

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Apr 25, 2006 at 09:41 PM

    Bela

    While specifying SOAP Receiver conversion Parameters check both the checkboxes in "DoNot use SOAP Envelope" and "Keep Headers" and tryout.

    Regards,

    ---Mohan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Mohan,

      I tryed with the keep headers option but it didn't change anything to the HTTP header fields.

      In the documentation we have the following : Keep Headers

      If you want to include the header of the XI message in the Web service message, set the indicator.

      Does it mean that I have to create a HTTP header section in the XI message??? Do you have an example?

      Best regards,

      Bela

  • Apr 26, 2006 at 09:04 AM

    Hi,

    in most cases you can easily change it in your

    own adapter module - method - setContentType

    Regards,

    michal

    -


    <a href="/people/michal.krawczyk2/blog/2005/06/28/xipi-faq-frequently-asked-questions">XI FAQ - Frequently Asked Questions</a>

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Michal,

      Thanks for your answer, gave very useful direction.

      For the content type no need to develop your own module with the module= localejbs/AF_Modules/MessageTransformBean and parameter name= Transform.ContentTypeit works fine.

      Best regards and thanks for your messages,

      Bela

  • Apr 26, 2006 at 10:08 AM

    check wether you can overwrite in reciever agreements.you have the header mapping there..

    Add comment
    10|10000 characters needed characters exceeded