Skip to Content
0
Jan 21, 2021 at 11:12 AM

OpenSAP : Evolved web app SAPUI5 - W3U1 - Problem with GWSAMPLE from ES5

32 Views Last edit Jan 21, 2021 at 02:22 PM 6 rev

Hello experts,

I'm currently following a SAP course led by Benedikt Schoelch and i have to setup a Master-Detail project template in SAP Web IDE from trial cloud foundry with the service GWSAMPLE from ES5.

I follow every steps of the course but when it comes to test the app with the OData service i have the following error :

sap-commu-01.png

I have the same error when i try to launch the app from the cloned github repository...

First i used the version 1.60 of SAPUI5 (to match the course version), so i tried 1.85 but same problem...

I have used the wizzard without encountering any problem, i could select my GWSAMPLE service and set my parameters.

NB: Using mock datas is working so that's why i guess the problem is from GWSAMPLE service as i haven't touched any file of the project yet...

Also i have setup correctly the endpoint in the "preferences" of my workspace and i use this endpoint in my project.

I'm stuck...Any idea please?

Edit : Chrome dev tool errors

chrome-error.png

Edit 2: i tried a worklist application template with the same sample service and same entitySet and it's working.

worklist-app.png

Regards,

Alexandre

Attachments

sap-commu-01.png (11.4 kB)
chrome-error.png (76.1 kB)
worklist-app.png (79.1 kB)