Skip to Content
1
Dec 15, 2020 at 11:22 AM

A route requires access to service but the service is not bound

414 Views Last edit Jun 24 at 04:09 PM 2 rev

My name is Jose and I am a colleague for NSC Portugal. I am working on a solution for a client where we aim to make an enhancement to the Asset Intelligence Network (AIN) documents application (aka manageattachemnts). And I got stuck with an issue [Format validation failed (A route requires access to html5-apps-repo-rt service but the service is not bound].

To achieve this solution we need to consume the AIN resources, in our specific case the Asset Central Service and the SAP Asset Intelligence html5 runtime service. There is an example on how to achieve this using web ide: https://help.sap.com/viewer/e5b513b9d15c455a9ae63569227c74fd/1911/enUS/06ee7e5d349c4532b5e1659dd66d22c8.html

I tried different solutions both using web ide and Business Aplication Studio (BAS).

In both web-ide and BAS (both locally and when deployed) the error is always the same:

I tried all possible variations of these files, even stupid things like setting the services as destinations, locally using both the bas for binds and making them "by hand".

This is the mta.yml for the app-router:

This is showing the local-env (for local testing), the xs.app with the routes to the mentioned services plus the xsuaa for the authentication.

xs-security.json:

This are the two services from AIN that are deployed in the account:

Both the local bind, as the bind by the require mta.yml, as the bind in the cockpit “by hand”, give the same error. I have already exchanged routs between the two xs.app's the app-router and uimodule and even with both. I tried all possible variations of xs.security for authentication. This is all at BAS. Even on the web-ide when running the app that is generated every time, the error when we run the application it is the same.

Below is some of the documentation I followed and similar erros and solutions that I have found and tried.

Integration with HTML5 Application Repository:

https://help.sap.com/viewer/65de2977205c403bbc107264b8eccf4b/Cloud/en-US/1e0424b4e1d8441ebb245c4d1e6bb0e5.html

Resolution of the same error in BAS, (I never get it to work) [locally]

https://blogs.sap.com/2020/08/09/timesheet-management-with-cap-trello-%E2%8F%B1%EF%B8%8F-setup-the-ide-mta-project-1/

Latest sap answers latest with the same error:

https://answers.sap.com/questions/13189691/sap-business-application-studio-destinations-for-r.html

Same error but with destinations:

https://answers.sap.com/questions/13039831/mta-deployment-error-in-the-webide.html

I tried all their examples step by step, even tried to generate new applications with just a bind to the service etc. The only thing that occurs to me is that these services may not be well configured and may not accept binds from applications that are not in the same repo or something.
If you have any idea on a possible solution I would be really grateful.

Thank you,

José Medeiros

Attachments

lk4xj.png (5.5 kB)
adtav.png (17.5 kB)
yuajj.png (75.7 kB)
zehly.png (93.2 kB)
9glja.png (59.9 kB)
s34l0.png (59.9 kB)
npaq4.png (59.9 kB)
m7o24.png (93.2 kB)
hlqdr.png (59.9 kB)
yoimy.png (93.2 kB)