Skip to Content

Getting the "SAP MII Plugin" for SAP Web IDE working

Hello everybody,

I have been trying for some time to get the SAP MII Plugin for WEB IDE working with our MII system, but so far I have not been able to get the MII-Destination to appear when I am trying to import something:

All the connections seem to be working fine - see below pictures. Also for my configurations.

I have the MII-Role SAP_XMII_WebIDE_User as mentioned in the How-To Document (http://sapassets.edgesuite.net/sapcom/docs/2016/11/6c7ee614-987c-0010-82c7-eda71af511fa.pdf )

I have tried with different principal types in the Cloud Connector (X.509 is not possible since we have HTTP not HTTPS).

I have tried with PrincipalPropagation (as requested in the document) and BasicAuthentication for the Destination in HCP, also with different Additional Properties, but nothing seems to make a difference.

With something like:

https://webide-pXXXXXXXXXXtrial.dispatcher.hanatrial.ondemand.com/destinations/MII_Dest/XMII/IlluminatorOData/Rowset(QueryTemplate='MIIProject/Query',RowsetId=1/Row

I can get data from MII, so I guess the connection itself should be fine.

--------------

--> What I would like to understand is, what are the preconditions for the plugin to show or not show the MII-Destination when trying to import a project ???

--> What could be the problem?

Thanks a lot in advance for your help and please let me know if you need any additional information.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Mar 15, 2017 at 07:50 AM

    Thanks a lot for your help Priyanka !

    The destination is appearing now and it can be selected for Import.

    However, we still receive an error message unfortunately:

    This is what the log in the Cloud Connector says:

    2017-03-15 08:42:03,918 +0100#INFO#com.sap.core.connectivity.protocol.http.handlers.HttpProtocolOutboundHandler#tunnelclient-6-1#0x047f40fa#Access denied to /WebIDECatalog?Mode=GetProject&content-type=text/json for virtual host miisp3:53000|

    The URL path in the Cloud Connector was changed to /XMII/WebIDECatalog according to your input:

    Any idea what could cause this error ?

    Maybe some issue with the Principal Propagation / X.509 ?


    Thanks again in advance!

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 01, 2017 at 03:06 PM

    Hi,

    I resolved this problem adding "XMII" end of URL ( "http://1.1.1.1:50000/XMII" ) and we can import MII projects .

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 10, 2017 at 05:26 PM

    Add /XMII/ to the URL path in the destination

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 06, 2017 at 02:42 PM

    Have the same problem and looking for solutions.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 13, 2017 at 04:12 PM

    Hi Daniel,

    I see that MII destination itself if not appearing in the dropdown, can u please check in destination configuration in cockpit, 2 additional properties should be added

    WebIDEEnabled : true and WebIDEUsage: MII_Dest

    Please let me know in case if it din't work.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 13, 2017 at 04:34 PM

    Hi,

    One more thing i see is in cloud connector the path to be exposed is /XMII/WebIDECatalog paths and sub paths.

    Please let me know in case of any issues.

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks a lot for your help Priyanka !

      The destination is appearing now and it can be selected for Import.

      However, we still receive an error message unfortunately:

      This is what the log in the Cloud Connector says:

      2017-03-15 08:42:03,918 +0100#INFO#com.sap.core.connectivity.protocol.http.handlers.HttpProtocolOutboundHandler#tunnelclient-6-1#0x047f40fa#Access denied to /WebIDECatalog?Mode=GetProject&content-type=text/json for virtual host miisp3:53000|

      The URL path in the Cloud Connector was changed to /XMII/WebIDECatalog according to your input:

      Any idea what could cause this error ?

      Maybe some issue with the Principal Propagation / X.509 ?


      Thanks again in advance!

      mii-error.png (10.1 kB)
      path.png (4.6 kB)