Skip to Content
0
Dec 02, 2020 at 08:54 AM

Error adding (external) cmis repository to Document Management Application Option on SCP CF

100 Views Last edit Dec 02, 2020 at 09:55 AM 5 rev

Hi Community,

we subscriped to SAP Document Management Integration Option and SAP Document Application Option and are trying to go our first steps with it.

So i tried to connect our internal (non sap) cmis repository (based on apace chemistry) in the Fiori Application of the DMS Application Option.

But i only get an error "failed to add a repository" with no further information on the error.

Because of this, i tried to add the external alfresco cmis server and its default-repository. I'm getting the same error.

I took these steps for Alfresco:

1) Adding a destionation to the public alfresco server

2) Check connection says Ok:

3) Added Repository to DMS Application Option as follows:

This brings also the same error message (failed to add a respository).

The Atom description of Alfresco CMIS-Server says following about the repository (only first rows shown here, full information available on alfrescos web-page).

I tried already all url variants in the destination configuration, but noone helped.

The only hint i found in the browser console is the failed request:

With messages (with the url in destination as shown above in screenshot)

or (with url: https://cmis.alfresco.com/alfresco and other paths below this)

based on the url i try in the destination to the alfresco public service.

Trying to connect to our own cmis-instance (based on apache chemistry) returns also http error 500 with the last json error message.

I'm running out of ideas? Does anyone have an idea whats wrong?

kind regards

Matthias

Attachments

cmis-dest.jpg (29.4 kB)
cmis-dest-ok.jpg (12.1 kB)
cmis-dms-add.jpg (32.4 kB)
cmis-error-req.jpg (40.4 kB)