Skip to Content
avatar image
Former Member

Not able to see T_IOT_HTTP_PUSH table in IoT and in hana DB.

Hello,

Am new to IOT, recently we have started on IOT, We had pushed messages from "Push Messages to Devices" from MMS cockpit, and table "T_IOT_HTTP_PUSH" got created.

But because of some issue i deleted the table from HANA DB, by right click the option as "Delete".

Now again i pushed the messages from MMS cockpit, there status as 202 is showing, But table is not showing in "Display Stored Messages" and in Hana table also.

Please help me how to resolve this issue.

Thanks,

Preethi

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Feb 17, 2017 at 07:31 AM

    Solution: IoT MMS had to be re-started to clean-up its "known DB tables" list. After cache was cleaned, IoT MMS was able to create a missing table on the fly.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 16, 2017 at 05:10 PM

    Hello Preethi, IoT MMS creates its tables on the fly (T_IOT_HTTP table as well). What push method you used when you sent messages to the device? A table keeps "http" messages only. In case you still do not have that table, I would need to have your landscape and account id to check the logs (you may share them privately via direct message to me). Regards, Anton

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 17, 2017 at 04:35 AM

    Hi Anton,

    Thanks for the reply,

    Please find the screenshot.


    mms-cockpit.pngpush-service.png

    Add comment
    10|10000 characters needed characters exceeded