Skip to Content
Nov 22, 2020 at 10:40 AM

SCP Cloud Foundry Gateway Destination Service not Available in Business Application Studio

419 Views Last edit Nov 23, 2020 at 10:06 AM 10 rev

Hi Guys,

I tried to find this issue on the forums but couldn't (perhaps I'm not searching correctly) and I was hoping someone could help shed some light on it.

The issue I'm having is that I'm trying to connect a simple UI5 application in the Business Application Studio, to a local backend service (SAP Developer Trial 7.52) via the SAP Cloud Connector. I can connect to the SAP system via the wizard but no services show up:

I used to be able to access the list of services in the SCP Neo environment but now in Cloud Foundry they don't appear. I have upgraded my backend system since moving to cloud foundry.

I've checked my services in SICF and they're all fine when testing in the browser. SAP Cloud connector must at least be connected to my cloud foundry sub account because in the screenshot above I'm able to log in to the system.

Here is how the resources are confgured in SCC:

I've got a few services up and running that I can access via Postman/ the browser and I receive the correct response (including adt_srv).

My Desination configuration in cloud foundry:


I have also tried with an ES5 Gateway demo system and it works, I can see the list of services:

Perhaps I'm missing something from the SAP backend system istelf (configurtation in SICF) or have I not configured the Cloud Connector correctly? Or maybe I'm missing a step in cloud foundry itself?

Any help or guidance would be very much appreciated!



sap-community3.png (44.8 kB)