Skip to Content
Nov 16, 2020 at 06:36 PM

Se16N field names not showing correctly

1091 Views Last edit Nov 17, 2020 at 08:24 AM 2 rev

I created a database table through se11. Then the client requested that when they look at the table in se16n, each field should have a distinct field name so that it will be easier to understand. For that I created each field a custom DE from the same old domain with field labels and a translation. In total there are 14 fields which needed a custom DE, plus the key field which did not change through this whole process.

But the table wouldn't work well. Before I hit F8 in se16n, the field name column shows all the correct names, but when I run it it shows incorrect names.

I.E.: when I used only 1 of the custom DEs, it worked. When I used the same DE on all fields, it worked. But as soon as I used the same DE on all fields but changed 2 of them to other custom DEs, it kept showing it as if they all had the same DE.

We tried using general SAP DEs like begda and endda and switching between them, but as soon as we enter one of my DE's it gets stuck with the field name of the begda or endda. Also sometimes it would work in one language but not the other.

One time suddenly everything worked, in both languages, but I noticed a typo in 1 of the translations so I fixed it (literally just changed Tasj1 to Task1) and everything stopped working again.

Tries logging out and logging in, hitting ctrl+s and ctrl+f3 pretty much everywhere, deleted both the table and all the DEs and tried working my way through the table from scratch but it just keeps showing incorrect field names! (Sometimes it would just show incorrect names but sometimes it wouldn't show any fieldname and the column would be super small.)

The table is a general, normal table, and all the DE's I created are also normal ones with no extraordinary qualities. I know because I tried creating everything from scratch while my manager+another team member watched, and yet it won't work.

It should be noted that the key field was not changed through the whole process, and also showed a correct field name every time.

Any help is appreciated.