Skip to Content
Former Member
Nov 08, 2020 at 03:40 PM

Docker installation of "AS ABAP 7.52 SP04" hangs



On a base Debian/testing system, I have downloaded 7.52 SP04 and verified the checksum of all parts, so far so good.

Starting from an empty /var/lib/docker and with dockerd stopped, I added the following /etc/docker/daemon.json:

{ "storage-opt": [ "dm.basesize=60G" ] }   

Additionally, I have executed:

sudo sysctl -w vm.max_map_count=1000000

After that, I started Docker 19.03.13 and verified that it worked with the hello-world example.

With regards to NW,I have found, and tried, a number of slightly different Dockerfiles

but they all hang at the same point and this is the last message I see:

INFO       2020-11-08 14:17:52.945 (root/sapinst) (startInstallation) [iaxxbfile.cpp:594] id=syslib.filesystem.aclSetSucceeded CIaOsFile::chmod_impl(3,0755)

Authorizations set for /sybase/NPL/startase_reset_sa.

At this point, activity appears to stall: CPU load drops to idle and there is no noticeable disk activity. The docker partition only occupies 24% of about 160GB. This happens also without the daemon.json, again starting from scratch.

If I run strace against "sh /sybase/NPL/startase_reset_sa", I see it is stuck waiting for the child process, which is /sybase/NPL/ASE-16_0/bin/dataserver.


  • Has anyone else met with this or a similar problem?
  • Is Docker a supported installation method? Or should I, say, try VirtualBox?