Skip to Content
1
Nov 03, 2020 at 08:21 AM

Service Layer URI length

95 Views

Hi,

When sending a Get request to Service Layer, I passed a long filter. something like

$filter=startswith(Table/Field,'A1') or startswith(Table/Field,'A2') ....

SL returns me error

{
 "error": {
 "code": 201,
 "message": {
 "lang": "en-us",
 "value": "Not supported query option: Mismatched parentheses"
 }
 }
}

I believe this is because my query string is too long ( >2200 characters)

When I remove some of the filter until it is abt 2050, the request is successfull.

Is there anywhere we can set the maximum length of the query params?

Regards

Edy