Skip to Content
avatar image
Former Member

JMS receiver adapter question

We are using WebsphereMQ protocol and we convert simple xml structure to MQ string. At the end of each message, we get a line feed (LF) is there a way to remove this? The message is being sent to Mainframe and it will not accept line feeds.

Thank you.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Apr 20, 2006 at 05:57 PM

    Parimala

    When you configure your reciever JMS Adapter the "Mapping of Message" parameter should be Message Payload = JMS Payload. Also in the message payload check that after completion of your message there is no line break.

    For further info. follow the url:

    http://help.sap.com/saphelp_nw04s/helpdata/en/10/b1b4c8575a6e47954ad63438d303e4/content.htm

    http://help.sap.com/saphelp_nw04s/helpdata/en/c1/739c4186c2a409e10000000a155106/content.htm

    ---Mohan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Do you see LF between messages. I would like to eliminate them for good. My mapping of message points to Message Payload = JMS Payload.