Skip to Content
0
Oct 26, 2020 at 09:10 PM

Is there a workaround for lack of Oracle 12c support in the Java libraries?

222 Views

I am in the process of migrating the rendering of a bunch of old reports from an old VB.net based app to a Java-based service. The data is in an Oracle 12c database and the reports include FULL OUTER JOINs. The Java library which determines the capabilities of the database seems to explicitly check that the database version string starts with either "Oracle Database 10" or "Oracle Database 11" to determine whether to treat it as a "newer" database which supports FULL OUTER JOIN, however 12c fails this check and throws an exception. Is there a newer version somewhere that I am not seeing that addresses this or is there any workaround that anyone is aware of?

Runtime: Implementation-Version: 12.2.226.3772