Skip to Content
0
Sep 16, 2020 at 10:06 PM

Multitenancy provisioning API and provider account application

308 Views

Hi Community

Thanks to Andrew Lunde for his great blog on the CAP multitenancy solution I have a the multitenat application up and running in my production account. Subscribing and unsubscribing work and I can connect to and confirm the data separation is occurring in the HDI containers.

I have two issues relating to the same error message. Should I be able to use the multitenant application in the provider subaccount? As I mentioned, it is deployed and subscriptions are working fine. I have now added securoty roles to myself in the provider account and open the application link. I am presented with error message:

{"error":{"code":"null","message":"Internal Server Error"}}

When looking at the logs of the srv, I see the following:

I was advised I neede to run the provisioning API to 'subscribe' as the provider so I am using the postman collection provided in the CAP documentation. When I execute the /mtx/v1/provisioning/tenant/<<tenantid>> I receive the same error message and the same entries in the log.

My first question is - is the tenant id required for this URL the id of the subdomain? Looking at the pattern for the subscriber accounts, this appears to be the case but would like to confirm this.

I then thought maybe it is a provider account issue, so I thought I would confirm the provisioning URL is working by creating a subaccount for a new subscriber and using the sub account id as the tenantid for the /mtx/v1/provisioning/tenant/<<tenantId>>. However, I got the exact same error for the subscriber account.

Am I using the provisioning API incorrectly? What is the actual origin of the error message instance.credentials are missing and what is the cause? It is curious that I am getting this message from both the provisioning API and when I try and execute the app in the provider account.

I can see that it has been raised before in this question, but is not addressed in terms of this scenario.

Any insights appreciated.

Regards

Neil

Attachments

bkijd.png (65.1 kB)
awsd0.png (65.1 kB)