Skip to Content

Error when creating an Universe Data Foundation using IDT against the Google BigQuery data

10.jpg11.jpg12.jpg13.jpg14.jpg15.jpg

Hello Everyone,

We have a bug in BigQuery with SAP BO IDT that lets us insert the tables in the data Foundation but when retrieving values from the tables or joins between the tables we get this error: -> [Simba] [BigQuery] (70 ) Invalid query .Unrecognized name D70_DIMENSION. D70_DIMENSION is the name of one of the datasets The connection to the database does not give a problem. In fact, as you can, we can retrieve the tables from the google big query dataset,

We use sap bo idt version 4.2 support pack 6 and for BigQuery is EI API V2

Please see screenshots below

I have read that it is an Bug :

https://stackoverflow.com/questions/59877671/error-when-calling-bigquery-stored-procedure-from-ssis-using-simba-odbc-driver

I'm from Google Cloud Platform Support.

I can see that this issue is already being investigated internally. I created a Public Issue in our Tracker regarding this, so you can subscribe to or star it to receive a notification whenever an update is posted.

Could you help me to solve it?

Thanks in advance

Best Regards

Antonio

10.jpg (237.9 kB)
11.jpg (222.6 kB)
12.jpg (217.0 kB)
13.jpg (205.7 kB)
14.jpg (202.0 kB)
15.jpg (209.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Sep 03 at 10:45 PM

    the problem that the simba odbc driver does not support "Owner" to be included in the select statement by "Standard SQL"

    ex: select Owner.TabName.ColName1 from Owner.TabName

    "Owner" in your case is the "D70_DIMENSION"

    ...

    There are two solutions to this problem:

    1. use "Legacy SQL"

    * In your "Simba ODBC driver for Google BigQuery DSN configuration", choose "Advance Options", then from the dialog choose Language Dialect "Legycy SQL"

    * Test it and it should work.

    .....

    2. by using "Standard SQL"

    * In the "odbc.prm" file in the ".... \SAP BusinessObjects Enterprise XI 4.0\dataAccess\connectionServer\odbc\extensions\qt" directory, change the "OWNER" parameter to "N".

    <Parameter Name="OWNER">N</Parameter>

    (Of course, make a copy of the file before making any changes.)

    * In your "Simba ODBC driver for Google BigQuery DSN configuration" set the dataset to the name of the dataset you are using (in your case "D70_DIMENSION").

    * Close and start the IDT.

    * Test it and it should work.

    ....

    hope that helps


    lsql.jpg (16.7 kB)
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.