Skip to Content
0

ZSOLMANPRO (ChaRM) Business Role SolMan 7.2 (cannot search SMAI, SMIM)

Feb 16, 2017 at 02:14 AM

837

avatar image
Former Member

Hi

We have just upgraded to SolMan 7.2 and I have just configured ChaRM. We have one issue which is making me go a bit crazy :)

Firstly, we are using these transaction types:

ZMCR
ZMHF
ZMTM
ZMMJ
ZMCG
ZMAD
ZMIN
SMAI (as recommended, we didn't copy this to Z)
SMIM (as recommended, we didn't copy this to Z)

In the CRM Web Client UI, I can search for ZMHF, ZMTM, ZMMJ, ZMCG, ZMCR, ZMAD, ZMIN.

However, I CANNOT search for SMAI or SMIM. Anyone know why?

If I revert back to SOLMANPRO business role, I can search for SMAI and SMIN...it's only in ZSOLMANPRO I cannot.


How do I resolve?

Thanks
Shaun

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Best Answer
Prakhar Saxena Feb 17, 2017 at 09:58 AM
0

Hi Shaun,

Yes we fixed the issue in SP3 not SP4 and change cycle is the right option in SP4. I think issue is something else in your case but can't check remotely.

I would suggest you to raise oss so that sap can login and check the issue in your case.

Thanks

Prakhar

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 16, 2017 at 02:32 AM
0

Ok, I know why this is happening.

The area to fix is SPRO > Assign Implementation to Change Transaction Type.

In here, SMAI and SMIM are both set to "Change Cycle". If I change SMAI to "Maintenance Cycle" and SMIM to "Project Cycle" it works.

However, I have changed these both back to "Change Cycle" as I don't want to customize SAP standard.

So how do I assign Change Cycle to ZSOLMANPRO?

Thanks
Shaun

Share
10 |10000 characters needed characters left characters exceeded
Prakhar Saxena Feb 16, 2017 at 11:09 AM
0

Hi Shaun,

We have faced similarly issue post upgrade in one of our customer case where below SAP note helped us to resolve it.

SAP Note 2375508 - Customer Change cycles

Please check and do the needful.

This should resolve

Thanks

Prakhar

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thanks Prakhar!

Looks like my fix is the same as described in the Note :)

The only other question I have is:

The "Document Type" (on the Search > Change Cycles screen) defaults to Change Cycle (Old). When I test SAP standard, it defaults to Change Cycle. How do I change this so it defaults to Change Cycle.

Thanks very much.

Shaun

0
avatar image
Former Member Feb 16, 2017 at 11:25 PM
0

Actually, this hasn't resolved it :(

We are on SolMan 7.2 SP4. This note is not valid.

When I go into table TSOCM_PROXY_IMPL (as described in the Note), there is no option for "Release Cycle".

I thought I would be smart and choose Maintenance Cycle (SMAI) and Project Cycle (SMIM) and this did fix my issue...but now I cannot create change cycles!! So I had to change it back to "Change Cycle".

How come I cannot see Release Cycle?

Share
10 |10000 characters needed characters left characters exceeded
Prakhar Saxena Feb 17, 2017 at 09:58 AM
0

Hi Shaun,

Yes we fixed the issue in SP3 not SP4 and change cycle is the right option in SP4. I think issue is something else in your case but can't check remotely.

I would suggest you to raise oss so that sap can login and check the issue in your case.

Thanks

Prakhar

Share
10 |10000 characters needed characters left characters exceeded
Shaun Kitching Mar 09, 2017 at 03:20 AM
0

Resolved because SMAI and SMIM had been updated to NOT have an early number assignment. Ticking this box fixed the issue.

I must say that is a very weird fix as it wasn't even relevant to the issue. But it fixed it!

Share
10 |10000 characters needed characters left characters exceeded