Skip to Content

Can't get Scripting API to use another theme than the "classic theme" SAP GUI 7.4

Hello Guys. I'm facing the same issue from this post (https://answers.sap.com/questions/10740734/sap-gui-scripting-uses-wrong-theme.html) and I already tried to do the solution proposed but had no success on getting my EXCEL VBA script running without the classic theme.

I'm using SAP GUI 740 (homologated version in my company) and I just can't insert the wscript and excel paths in the "Application" setting menu. When I click the "Insert" button it just flahses the screen but no window gets opened, even when I run it as admin (it's the same issue as the following link and I tried the solution as wel, https://answers.sap.com/questions/13092606/sap-gui-configurations-visual-design-applications.html#). Then I found the SAP documentation that describes the registry values for these configs, I set them up mannualy and still can't get the script to open with any other theme than the classic one.

What I have already tried:

1. Check if "Applications" update was read only: No registry value AppsSapGuiVisualTheme_ReadOnly on both 32 and 64 Nodes:

2. Inserted the registry keys with the paths for for Excel, wscript and cscript (Both 32 and 64 Registry Nodes).

2.1 I tried to insert just "EXCEL.EXE" and the full path as well, on both 32 and 64 Nodes:

C:\Windows\System32\wscript.exe

C:\Windows\SysWOW64\wscript.exe  '----(On the Wow6432Node)

C:\Program Files (x86)\Microsoft Office\root\Office16\EXCEL.EXE

2.2 I tried to use "Enjoy" = "On" and "Off", and none of them worked. I also tried to insert "Streamline" = "On" just as a guess.

2.3 I could confirm that the registry key is OK because I can see it on the sapconfiguration application after I created the registry keys

Could you guys share the registry keys that is making this work for you so I can compare with mine? Thanks in advance.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Aug 21 at 03:01 PM

    Guys. It ended out that the config was recognized after a simple restart ��

    Add a comment
    10|10000 characters needed characters exceeded