Skip to Content

Unsupported response types:[Bid_token] in hybris Identity provider

Hi ,

We are trying to setup platform as Identity provider(In hybris version 18.0.8) and setting up that identity provider in Autho as

When Autho tries to contact platform, login details screen is poping up, if user enters proper authentication details, user is getting authenticated and then it is throwing error as "Unsupported responsetypes:[id_token].

When We see http://server/authorizationserver/.well-known/openid-configuration it shows below which says it supports.

Not sure why it is throwing that error.

"response_types_supported" : [ "code", "code id_token", "id_token", "token id_token" ]

Note: Also "http://server/authorizationserver/.well-known/jwks.json" is not showing any keys after adding configuration.

Can that be the root cause?

Appreciate any kind type of help.

Add a comment
10|10000 characters needed characters exceeded

Related questions

0 Answers

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.