Skip to Content

Error while creating business partner with CPI

Hello,

i tried to create a business partner in an IFlow with CPI. I used the BusinessPartner A2X API and the Comunication Scenario Arrangement SAP_COM_0008. Below is a snippet of my XML Code. I give it to the OData Adapter in the create Statement of the IFlow.

<?xml version="1.0" encoding="UTF-8"?>
<A_BusinessPartner>


<A_BusinessPartnerType>
<FirstName>User1</FirstName>
<BusinessPartnerCategory>1</BusinessPartnerCategory>
<FormOfAddress>0001</FormOfAddress>
<LastName>User1 LastName</LastName>
<OrganizationBPName1>User1 Org Name</OrganizationBPName1>
<SearchTerm1>Random</SearchTerm1>
<SearchTerm2>Random1</SearchTerm2>
<CorrespondenceLanguage>US</CorrespondenceLanguage>
<Industry>0000</Industry>
<Language>US</Language>

<to_BusinessPartnerAddress>
     <A_BusinessPartnerAddressType>
     <Country>US</Country>
     <Language>US</Language>
     <PostalCode>0000</PostalCode>
     <CityName>Random</CityName>
     <StreetName>Random Street 1</StreetName>
     </A_BusinessPartnerAddressType>
</to_BusinessPartnerAddress>

<to_BusinessPartnerRole>
   <A_BusinessPartnerRoleType>
   <BusinessPartnerRole>CRM000</BusinessPartnerRole>
</A_BusinessPartnerRoleType>
</to_BusinessPartnerRole>
</A_BusinessPartnerType>


<A_BusinessPartnerType>
<FirstName>User1</FirstName>
<BusinessPartnerCategory>1</BusinessPartnerCategory>
<FormOfAddress>0001</FormOfAddress>
<LastName>User1 LastName</LastName>
<OrganizationBPName1>User1 Org Name</OrganizationBPName1>
<SearchTerm1>Random</SearchTerm1>
<SearchTerm2>Random1</SearchTerm2>
<CorrespondenceLanguage>US</CorrespondenceLanguage>
<Industry>0000</Industry>
<Language>US</Language>

<to_BusinessPartnerAddress>
     <A_BusinessPartnerAddressType>
     <Country>US</Country>
     <Language>US</Language>
     <PostalCode>0000</PostalCode>
     <CityName>Random</CityName>
     <StreetName>Random Street 1</StreetName>
     </A_BusinessPartnerAddressType>
</to_BusinessPartnerAddress>

<to_BusinessPartnerRole>
   <A_BusinessPartnerRoleType>
   <BusinessPartnerRole>CRM002</BusinessPartnerRole>
</A_BusinessPartnerRoleType>
</to_BusinessPartnerRole>
</A_BusinessPartnerType>

</A_BusinessPartner>

If I run the snippet above, I only find the first entry with the Role CRM 000 and following that I get the error that is depicted in the snippet below.

<?xml version="1.0" encoding="utf-8"?><error xmlns="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"><code>R1/275</code><message xml:lang="en">No authorization to create partner in role</message>

My research lead me to KB 2920059. The mentioned solution is to Use the allready used SAP_COM_008 Cummunication Scenario Arrangement.

Add a comment
10|10000 characters needed characters exceeded

Related questions

0 Answers

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.