Skip to Content

SAC data acquisition layer encountered an internal error

Hello

We are having some problems with our BW import connection in SAC.
Until 1-2 weeks ago everything was working perfect, we had our SAC BW import connection and there were no problems.

Last week we noticed that our scheduled models with import BW data were no longer refreshing and we get following error:
See first image

When I try to create a new model I get: see second image

I checked everything at the connections page, I'm still able to create the connection to our BW application server withouth any error
.
The cloud connector is still configured correct and gives no errors.
All ports are open and the firewall is set correctly.

We have a Dev, test and Prod system, before it was working on all of them and now it is failing on all of them.
I also tried it with my test VM on which I installed the cloud connector before but with a different location name (here it was also working before and there are no firewall restrictions) and this one now also fails.

I can't find any logs on our BW system, checked SM37, ST22 and RFC logs in SM59 but not a single error to be found.

I also checked the developer tools when refreshing the data or creating the model, but again no errors.

And I checked the trace in SAC in the monitoring section, but also no errors here.


Does anyone have an idea what the problem might be?

Kind regards
Sven

capture.png (9.8 kB)
capture2.png (8.2 kB)
Add a comment
10|10000 characters needed characters exceeded

  • Hello Mark Fodor

    None of the tomcat files gives an error.
    And no I can't create a new model, as I said in my question when I try to create a new model I get the data acquisition service error, when I try to refresh the data I get the internal server error.

    Also a new thing that I found is, we got 2 SAC tenants (one for testing purpose and a production one). On the production we have the error. But when tested on the testing one it does work only 2differences is. The testing has a different subaccount (but both subaccounts are configured the same on the same cloud connector) and the version. For some reason our prod SAC is still on version 2019.15.5, while our testing one is at 2020.22.08.

    Kind regards
    Sven

  • Thanks Sven Swennen. If there is no error in Tomcat, most probably SAC isn't even able to communicate with Tomcat which means either there is a problem on the "tunnel" (which would be the Cloud Connector and/or the subaccount) or network as such (proxy, firewall). The subaccounts are different which is correct. If they are configured correctly and only prod is affected I would recommend you to reach out to product support.This is more effective in terms of exchanging information between you and SAP.(https://support.sap.com/en/index.html > Report an incident) Please put the incident number here in comment and i will monitor it.

    About versions: The version should be 2020.8.22 instead, seems to be on a QRC release. Other one I doubt with 2019.15.5, would make no sense. Rather something like 2020.16.1 expecting that this is a partner instance which is meant for testing purposes. But if you decide to go for a support ticket please mention the correct versions accordingly.

  • Hello Mark Fodor

    I reached out to the sap support team.
    There was a problem on the host side and SAP solved it themselves.
    So all the config on our side was correct.

    Unfortunately they didn't specify what they did or what the exact problem was only that the problem was on their host side.

    Kind regards
    Sven

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Aug 24 at 11:46 AM

    Hi Sven Swennen, thanks for the continuous updates. I had a follow up with the respective development team and was able to find the following. There was a process called data binding which resulted in a problem on the backend instance causing the data acquisition service to fail. We done the binding again successfully on 13th of Aug so all the related errors were gone for all the customer systems on that instance. Hope this explains a little more on the reason behind.

    Best regards, Mark

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.