Skip to Content

Issue on automatic completion of Inspection lot via QA40 / program RQEVAI50

Hello All,

We are closing Inspection lot using program RQEVAI50 as a background execution.

But getting an error message in log as 'No batch input data for dynpro SAPLSTXX 1100'.

In initial debugging we found that, a standard text window appearing on SAVE action of QA11 t-code.

In program RQEVAI50, BDC is recorded for t-code QA11, but there is missing entry for this text window.

Due to this the completion status is not set.

Need help to understand if there is any customization can be done to avoid it.qa40l.png

qa40l.png (125.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Jul 28, 2020 at 12:02 PM

    Is this happening for all lots or just some?

    What's happening is in the BDC you are getting a screen that is not expected and the necessary info isn't available for it.

    Look at the lots that don't work. My guess is there some difference in the master data of those lots. If it fails on all lots, you must have changed some process that results in the additional screen.

    I think you need an ABAP'er to trace it.

    Craig

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.