Skip to Content

Content Enricher not working as expected

Hi Experts,

I want to enrich the message in CPI with some details.

Requirement -> Fetch employee userid, leave start date and leave end date. Now based on this user id fetch Delegate details where userId=AutoDelegateConfig_delegator

However the enricher step is not getting called.

Please see the screenshot for more details-

AutoDelegateDetails:

Enricher:

Can anyone please help me identify the config error here?

Regards,

Akash

step.png (50.2 kB)
employeetime.png (46.4 kB)
enricher.png (65.3 kB)
dynamic-query.png (19.0 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Jul 19, 2020 at 02:43 PM

    Hi Akash Shrivastava,

    Does it mean its getting called when you are using combine and its not working with enrich ?

    If you could see the values combine then definitely it's getting called. Could you see what is the data coming before Message mapping step.

    It could be possible for few User-ID's there is no valid values.

    thanks and regards,

    Praveen T

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 19, 2020 at 01:55 PM

    Hi Akash Shrivastava,

    Could you try removing the "/" in beginning of path to Node.

    In addtition request you to check below blog to use the Enricher step optimally.

    https://blogs.sap.com/2019/11/08/handling-large-data-with-content-enricher-and-odata-v2-adapter/

    Hope this helps

    thanks and regards,

    Praveen T

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 19, 2020 at 02:30 PM

    Hi Akash Shrivastava,

    Could you try to change the Aggregation algorithm to Combine and check if you are getting two XML's. If not please try to make API call to AutoDelegateAPI in a separate i-flow and check if you have right set of data.

    thanks and regards,

    Praveen T

    Add a comment
    10|10000 characters needed characters exceeded