Skip to Content

Data quality rule for business partner error occured when retrieving rules from rule set in BRFplus

Hi All

We are trying to use the DQM app to create BRF+ rules for data quality evaluation and checking BRF+ rules in change request. APP id : F4082

I tried via manually creating DQM BRF+ rule and also via Manage rule mining App but received errors in both situations.

Any pointers to resolve this issue?

1aehd.png (15.5 kB)
ktnyi.png (9.3 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Aug 05, 2020 at 05:48 AM

    Markus Ganser this issue was fixed by SAP note 2951664

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 23, 2020 at 09:52 AM

    I'd recommend to post a customer ticket.

    FYI - There's a new how-to guide available about rule creation.

    Add a comment
    10|10000 characters needed characters exceeded

    • Thanks Markus

      I would like to let you know that I resolved this issue partially via workaround.

      We created and deleted BRF+ rules in the APP for DQM rules, but when checking backend tables, we found out that there are orphaned BRF+ objects which are creating the actual issue. We had manually clean up all such BRF+ objects and it started working again for manual creation of rules.

      However, the creation of BRF+ rules via Rule mining (DQM) is still not working.

      I will post a customer ticket for the same. However, SAP response is very slow for the sandbox and quality systems, that we might not get a response in 2 weeks. Thats why I post it on SCN, where great SAP experts like you could help.

      Regards

      Ashish

  • Posted on Aug 04, 2020 at 12:24 PM

    Thanks Markus Ganser for the document. it helped.

    However, could you specify if there is a customizing available for Master data quality management configuration. I have configured below two:

    1. All implementation steps from SAP fiori library for the evaluation app.

    2. Activated BC set CA-MDG-ADQ-BP_EVA-PRC.

    I have checked corresponding sicf services are active.

    My Evaluation process is stuck at step 1 and is requesting user input. As per my understanding, evaluation should work out of the box. Support ticket to sap is very slow in response for non production system.

    Add a comment
    10|10000 characters needed characters exceeded