Skip to Content

XSA - Access _sys_bic column view from HDI container

Hi,

I need to access a column view in schema _SYS_BIC from the HDI container using flowgraphs. I now have the right authorizations in place but when the view is queried it returns no data once it requires the session client. I cannot give that directly in Hana Studio to the OO user. How can I fix this?


Thanks in advance.

NM

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Jul 16, 2020 at 09:54 AM

    Hi Nuno,

    the actual calling user is relevant for the session client. Thus it depends on how you execute the flowgraph. If you execute it directly from Web IDE a ...._RT user will be used.

    To set the client you basically have two options (user specific or session specific):

    user specific: alter the user client as you tried for OO but for the executing user

    session specific: set the client when establishing your connection. For example, if you connect from Database Explorer there is an option "Advanced Options". If you enter here something like CLIENT=100 the client value 100 will be taken when executing through this connection.

    Given the complexity of changing the client of the executing user or when creating the connection, I am wondering whether it would not be a better solution to filter directly on the column instead of relying on the "implicit" client filtering. For example, you could set your view to "Cross Client" so that no client filtering occurs anymore and explicitly define a filter on the client column.

    Best,

    Jan

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 16, 2020 at 11:42 AM

    Hi Jan,

    many thanks for your valuable feedback. Once the view is maintained by external team, I think I have to go with the first option (user specific or session specific).


    For a session specific, how can I set the CLIENT= 100 in the advanced options? When I choose "Open HDI Container" from Development view, I creates a connection but I cannot change the advanced options (it's greyed out). How can I add the CLIENT = 100? Is it in the MTA file?

    Many Many thanks.

    Kind regards,

    NM

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 16, 2020 at 01:19 PM

    Hi Nuno,

    if you go for the connection specific setting in Database Explorer you could add a new HDI container connection and select the already existing container in the dialog. While adding it as a new connection you can modify the Advanced Options.

    Best,

    Jan

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.