Skip to Content

SAP Business Objects Edge XI 3.1 SP3 does not run on Windows 10

Has anybody knowledge if SAP BOE XI 3.1 can run on Windows 10 or not?
I know, that officialy is not supported, but does anybody has tested it if it works or does not work?

According to our tests it is possible to install it, run Designer, but for example Web Inteligence Rich Client does not start.

Is anybody aware of any workaroud how to fix it (install higher service pack or so), or there is simly no way?

Add a comment
10|10000 characters needed characters exceeded

  • Thanks for valuable comments.

    It is a bit strange, but when we uninstalled and installed again SAP BOE on the same computer with Windows10 then it starts to work. It is true, that we played a bit with Compatibility tab on shortcut of WebI Rich Client, but then we reverted all changes back and application still runs.

    So we can confirm, that SAP BOE XI 3.1 SP3 runs (as server and also as client) on WindowsXP, Windows7 Pro and Windows10 Pro 1909 (at least these parts: Central Management Console, InfoView, Designer and Web Intelligence Rich Client)

    (Java on computer is only Java installed by BOE, so version 1.5 in our case AFAIKS)

  • Btw. can somebody share download link to SAP BOE XI 3.1 SP7?

Related questions

3 Answers

  • Posted on Jul 08 at 06:22 PM

    Edge Xi3.1 Sp3 is a server product and will not run on client OS.
    If you're talking about client tools -- most likely they will not run on win10.
    They were designed and compiled using frameworks that we obsolete by the time win10 was released.
    And no, there is no way to make it work.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 08 at 06:27 PM

    We have installed BI3 client tools on Windows 10, It works eventhough it is not officially supported. But our version is latest of BO 3.1 sp7. Looks like your version is lot older. So I would suggest to atleast upgrade to SP7.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 08 at 08:26 PM

    A couple of things:

    1. You'll have to have an earlier version of Java (1.5 or 1.6, I believe) in order to run the Webi Rich Client.

    2. For other client tools, you can find the .exe files, right-click on each, and select "Troubleshoot Compatibility". That will let you run them as if they were running on an earlier version of Windows.

    -Dell

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.