Skip to Content
avatar image
Former Member

SP01: 2005 SP1 addon registration issue (PL03! - what about PL02?)

Hi.

I installed our development server to B1 version 2005 SP1 PL3. I then

tried to register our addon ard file and got the attached error message.

<b>"Wrong digital signature for Add-on installer"</b>

I tried attaching the same ard file and exe to B1 2005 SP0 PL9 and it worked fine.

Note: In our addon, we attach the ard file and the exe for the application directly to B1.

Please advise.

Message was edited by: Frank Moebius

Changed the subject a bit to draw attention from other testers to that issue.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Apr 14, 2006 at 03:45 PM

    Gopal,

    Did you recompile your code under SP01 and then try creating the .ard file?

    Eddy

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Gopal,

      Unfortunately I have to tell you that the issue I had found was not related to a bug in the Add-On Administration of B1 - or generation of digital signatures.

      It was a bug in the SDK sample (14.AddOnInstaller):

      Apparently it is generating an empty Add-On file in the target directory...

      Therefore the signature did not match in my case...

      So, you are "alone" again.

      Can you give us more details about your installer + how you create the ARD file?

      Regards,

      Frank