Skip to Content

in migo -How to Make field Document Date ( BLDAT ) disable

Hi all,

I want to make field BLDAT in MIGO disable not changeable,

I used 2 ways.

Badi and customer exit but not working like below,

1- in badi MB_MIGO_BADI and method PBO_DETAIL

LOOP AT SCREEN.
if screen-name = 'GODHEAD-BLDAT'.

screen-input = 0 .
ENDIF.
MODIFY SCREEN.
ENDLOOP.

2- in customer exit MBCF0002 .t

code the same badi .

what can I do ?.

thank you.

Add comment
10|10000 characters needed characters exceeded

2 Answers

  • Posted on Jun 30 at 06:55 AM

    Hello ALaa Azazy

    Actually you can achieve that with simple configuration setting in: Materials Management -> Inventory Management and Physical Inventory -> Settings for Goods Movement (MIGO) -> Field Selection for MIGO - just set GOHEAD-BLDAT field to display only.

    Best regards

    Dominik Tylczynski

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 29 at 03:06 PM

    Hi Alaa,

    This can be achieved through MIGO screen variant try through SHD0

    Regards,

    Add comment
    10|10000 characters needed characters exceeded