Skip to Content
0

How to enable HTTPS port on NW 7.0SP14

Feb 15, 2017 at 12:38 PM

716

avatar image

Hi All ,

We have java stack NW7.0 installed on Windows server 2008 R2 and SQL database .

We can access the url on http port e.g. http://hostname:50200/ but it is not accessible on https port i.e. 50201 .

We have followed the steps to enable https as per document https://help.sap.com/saphelp_nw70/helpdata/EN/bc/2ee9a2d023d64eac961745ea2cb503/frameset.htm

find attached step and parameter for HTTPS.java-version.pngicm-parameter.pngssl-certificate.png

Please suggest how to enable HTTPS port for Java stack 7.0

Regards,

Manish

java-version.png (89.0 kB)
icm-parameter.png (80.0 kB)
ssl-certificate.png (152.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

10 Answers

S Sriram Feb 15, 2017 at 01:13 PM
0
Share
10 |10000 characters needed characters left characters exceeded
Manish Tilvankar Feb 15, 2017 at 03:15 PM
0

Hi Sriram ,

Thanks for your response.

I have gone through the blog but it shows steps for ABAP stack.I am using only JAVA stack hence this did not work.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

did you restart engine after maintaining profile parameter? What error do you get when accessing via https://hostname:50201/?

Best regards,

Nick

0
Matt Fraser
Feb 15, 2017 at 11:54 PM
0

Hi Manish,

Are you sure you need the parameter icm/server_port_01? It has been a while since I first installed and configured SSL on a NetWeaver 7.00 Java system, but looking at my 7.01 portal, we don't have this parameter. I think that is used for either ABAP systems, or later versions of NW Java, but not in 7.0x.

Also, double-check that you have a current version of sapcrypto.dll in your kernel executables. Current kernels include this, but if you're still using a really old kernel (e.g. a 700 kernel), I'm not sure if it was included by default. I recall there was a time when that needed to be downloaded separately. If you still have a 7.00 (or even 7.20) kernel, you might want to first update to a 7.21 or 7.22 kernel (use SUM to do this). I believe those should both be downward-compatible to a 7.00 NetWeaver system.

Did you establish your certificate keypair as a server credential in Visual Administrator? In Visual Admin, navigate to Cluster -> Server x -> Services -> SSL Provider and select the Dispatcher runtime node, then the socket that matches your IP address and port (i.e., 50201). Select the Server Identity tab. You should see your keypair listed here as an Enabled Credential. If you don't, add it.

Cheers,
Matt

p.s. I changed the tag on this question to "SAP NetWeaver Application Server for Java," as the question is specific to the Java platform.

Share
10 |10000 characters needed characters left characters exceeded
Manish Tilvankar Feb 17, 2017 at 12:53 PM
0

Hi Matt ,

Thanks for your response.

I have upgraded the Kernel to 742 SP 28 and also checked setting in Cluster -> Server x -> Services -> SSL Provider ,Keypair is enabled

But still HTTPS is not working.

Please find the screenshot of the same.

visualadmin-setting.png latest-kernel.png

Regards,

Manish


Show 1 Share
10 |10000 characters needed characters left characters exceeded

The 742 kernel is not compatible with NetWeaver 7.0x systems. You should select a 721 or 722 kernel. I am surprised your system would even start with a 742 kernel. In fact, it wouldn't start, so I'm guessing you haven't completely updated the kernel to this.

0
Manish Tilvankar Feb 22, 2017 at 01:48 PM
0

Hi Matt ,

can you confirm if the above changes are fine or do we require some more checks and update .

Regards,

Manish

Show 1 Share
10 |10000 characters needed characters left characters exceeded

As a side note, the community platform only sends a notification to someone if there is a reply directly to their own activity, so I never received a notification for this or the previous answer you provided, as they were replies directly to your original question, not my answer. I know, this has confused a bunch of people.

0
Emoke Gabura
Feb 22, 2017 at 04:46 PM
0

Dear Manish,

Please be informed that I reviewed the configuration. The only screenshot missing is the Properties of the HTTP Provider service's Ports parameter but I assume that there is a port defined for type SSL there. So the ports parameter should be something like this where <xx> is your instance id:

(Port:5<xx>00,Type:http)(Port:5<xx>01,Type:ssl)

If this is the case, then your configuration seems to be correct.

Although, as Matt also stated, the icm/server_port_x parameter is unnecessary, since on a 7.0 environment you do not have ICM.

So the next step would be to advise what is the exact error you receive. Maybe check whether this port is open on network level.

Please share with us the exact error.

Thank you,

Emoke

Share
10 |10000 characters needed characters left characters exceeded
Matt Fraser
Feb 22, 2017 at 11:07 PM
0

Manish,

It looks like your enabled SSL credential, as shown in your screenshot above, is on port 50001, whereas I think you're using port 50201, aren't you? I believe this could be the source of your issue. If this is instance JC02, then the http port should be 50200 and the https port should be 50201, but that's not the port you've bound your SSL credential to.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Matt ,

you are right I have updated the Kernel to 742 but is it still using 7.0 as per system information tab on portal.

but I have already copied 742 sapexe and sapexedb file in existing kernel.

Regarding port number 50001 ,sorry that was wrong screenshot attached by mistake .please find correct port and http provider setting in attachment https-provider.png

also Find attached dispatcher Trace .

0
Manish,

You cannot use a 74x kernel with a 7.0x system; they are completely incompatible. You must use either a 721 or 722 kernel. You must fix this first, before anything else. Do not simply download and copy over sapexe and sapexedb kernel updates to Java systems -- use the Maintenance Planner to select compatible kernel updates for download, and use SUM to apply them correctly.

Cheers,
Matt

1
Manish Tilvankar Feb 26, 2017 at 07:18 PM
0

default-trace.txtHi Matt ,

you are right I have updated the Kernel to 742 but is it still using 7.0 as per system information tab on portal.

but I have already copied 742 sapexe and sapexedb file in existing kernel.

Regarding port number 50001 ,sorry that was wrong screenshot attached by mistake .please find correct port and http provider setting in attachment https-provider.png

also Find attached dispatcher Trace .


Share
10 |10000 characters needed characters left characters exceeded
Manish Tilvankar Mar 04, 2017 at 03:50 AM
0

Hi Matt ,

Please find the attached error log and suggest the solution.

Share
10 |10000 characters needed characters left characters exceeded
Manish Tilvankar Mar 14, 2017 at 11:26 AM
0

Hi Matt ,

have you seen the attached log .can you guide me to resolve the issue

Share
10 |10000 characters needed characters left characters exceeded