Skip to Content

Unable to access OData service created on SAP Cloud Environment from S/4 HANA On Premise system

Hi All

I am trying to create a HTTP RFC connection of type G in SM59 in my S/4 HANA system to access my OData service created on SAP Cloud Platform ABAP Environment. I have created RFC destination by providing host, OData path and Communication User and Password.

The response we are receiving is "404" - Not Found . Kindly help to resolve the issue.

Response Text is something as below

"HTTP/1.0 404 Not Found

Content-Type: text/html
Content-Length: 16052
cache-control: no-cache

<html>
<head>
<title>SAP Cloud Platform ABAP Environment - 503 Service Unavailable</title>
<style>
  body { background: #ffffff; text-align: center; width:100%; height:100%; overflow:hidden; }
  .content { display: table; position:absolute; width:100%; height:80%; }
  .valigned { display: table-cell; vertical-align: middle; }
  .lowerCenter { display: table-cell; vertical-align: bottom; }
Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on May 27 at 08:28 PM

    Hi,

    I would suspect this either to be a temporary issue or a wrong configuration of your RFC destination.

    Can you check you:

    • Enabled SSL in your RFC destination
    • Uploaded the SSL certificates in STRUST
    • Are able to call your service from e.g. Postman

    Best regards,

    Geert-Jan Klaps

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 28 at 07:20 AM

    Hi Geert-Jan Klaps

    Please find below screenshots

    Regards

    Swathi V


    capture1.jpg (69.2 kB)
    capture3.jpg (55.3 kB)
    capture2.jpg (50.2 kB)
    capture4.jpg (31.8 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • Hi,

      Can you make sure that:

      • Target host doesn't start with https://
      • Target host doesn't contain a trailing / in the end
      • Basic authentication contains a password (currently it seems to indicate that the password is not set

      If above is checked and it still doesn't work, maybe try changing the path prefix to your metadata URL.

      I also see that you're using a proxy configuration, if above is still not working => maybe double check with your IT department to see if the configuration is correct and if they can maybe trace the call your doing in SM59.

      Best regards,

      Geert-Jan Klaps

  • Posted on May 28 at 09:32 AM

    Hi Geert-Jan Klaps

    Thank you.

    Yeah. Ensured all the points mentioned by you. Still same issue.

    Regards

    Swathi V

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.