Skip to Content

events and approver table

HI Team,

Good day.

Could you please advise if there are tables to cross check the member events against the privileges and the assignment approvers assigned to the privileges ?

Also, we are facing some issue with searching.

for ex in the privilege tab, if I search with *Z_TEST_PRIV*, I am getting the results as

Z_TEST_PRIV and Z.TEST_PRIV.

This behavior is with only some roles. we have checked in the IdMv_LINK_EXT2 both have unique IDs and both are PRIVs.

Could you please advise.

Thanks,

Aravind.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on May 18 at 07:44 AM

    Hi Aravind,

    I think your post is a mix of several questions. IMHO it would make sense to split it up and ask each question separately.

    Events: Member events are defined on attributes and entrytypes. There is no view or table that I am aware of that lists them all. You need to check the relevant tables for attributes (mxi_attributes) and entrytypes (mxi_objectclasses). There you will find relevant columns like DELTASK, MODTASK or INSTASK.

    Assignment approver: If you are referring to a standard procedure like defining approvers as reference attribute MX_APPROVERS then you can find this relation in the LINK-Views like IDMV_LINK_EXT_ACTIVE.

    Search results: The results depend on the attributes defined for searching (search task of entrytype in combination with display task). Maybe this explains the effect already. Check for all attributes of the mentiones privs whether there are attribute that matches *Z_TEST_PRIV*.

    In case you need additional assistance please provide more and relevant infos.

    Regards,

    Alex

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Alex,

      Good day.

      For the below issue, we have checked both PRIV search and PRIV Display. But found nothing related to this issue (i might have missed something)

      the problem is coming only when i searched with "_" (Z_TEST_PRIV).

      When i searched Z.TEST_PRIV, it has given single entry. But when i searched Z_TEST_PRIV, i have received 2 entries as below.

      "for ex in the privilege tab, if I search with *Z_TEST_PRIV*, I am getting the results as

      Z_TEST_PRIV and Z.TEST_PRIV."


      IDM 8.0


      Search form :


      Display:

  • Posted on Jun 29 at 07:00 PM

    Hi All,

    Thank you for your support.

    Not sure why my screenshots of the error, are not added in the below message.

    Found 2635026 is relevant to my issue.

    Thanks,

    Aravind.

    Add a comment
    10|10000 characters needed characters exceeded