Skip to Content
0
May 08, 2020 at 04:03 PM

Datasever shutdown abruptly when dbcc dbreboot is used.

50 Views

Hi Experrts,

Issue background: While setting up Replication, instead of executing the script rs_install_primary.rs in the target site(TDS.D30) I executed it by mistake in secondary site. As soon as I realized, I deleted all the tables (20 in number with rs_*) from the database using "delete from" command and then when I tried executing the script rs_install_replicate.rs the execute was unsuccessful with innumerable errors and at the end permission issues. So then we tried to reboot the database alone using dbcc dbreboot command (I am not sure whether this is 100% documented but I noticed some shops using this).


All of a sudden during the execution of dbcc dbreboot('reboot',D30), TDS got shutdown and when I checked it's error log I noticed a timeslice -501. When we restarted the TDS, database D30 was in shutdown state and again we executed dbcc dbreboot to bring it back to online. Attaching the log for your advise.

What I would like to know here are,

1.Can't we execute the script rs_install_replicate.rs if we delete the objects that are created by rs_install_primary.rs? Is there any pre-requisite/care we should take before executing rs_install_replicate.rs in TDS.D30?
2.Is the command dbcc dbreboot 100% documented?
3.Why the impact is on the dataserver TDS though the command was just executed on D30 database alone?

NOTE: I am using RHEL 7 and the dataserver's version is 16.0 SSP03 PL08.time-slice-during-dbcc-dbreboot.txt

Regards,
Dilip Voora

Attachments