Skip to Content

Upgrade application from Crystal Reports 2008 to Crystal Reports 2016...

Hi There,

I had a request to upgrade Crystal Report from 2008 to 2016. I learnt that 2016 support 2008 reports so I downloaded only “CRRuntime_32bit_13_0_27.msi” for 32-bit application and installed on my system. But application did not work because it failed to find assemblies in GAC. I checked in “C:\Windows\assembly” folder and found only one assembly with the name “CrystalDecisions.Data.AdoDotNetInterop”.

Then I installed “CRRuntime_32bit_13_0_12.msi” and application worked fine.

1) Now I want to know if I need to buy license for crystal 2016? I only need runtime “CRRuntime_32bit_13_0_12.msi” or “CRRuntime_32bit_13_0_27.msi” for my reports generation. For RPT design I am already using licensed Crystal 2008.

2) Also, why “CRRuntime_32bit_13_0_27.msi” failed to install the assemblies in GAC (“C:\Windows\assembly”). Are there any dependencies missing in machine that I am using? I have .NET 3.5 and 4.0 installed on machine.

Note: I am not using crystal for personal use.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on May 12, 2020 at 02:15 PM

    In addition, you need to be logged in with Administrator privileges when you do the install and, for the integration with VS, you need to right-click on the .exe and select "Run as Administrator". The Crystal SDK requires a bunch of registry settings in order to be able to run correctly and these don't get set when you don't have Admin rights when installing.

    Finally, you'll also have to upgrade the version of Visual Studio that your application is compiled with. Crystal 2008 required VS 2008, the latest versions of the SDK require VS 2010 or newer. The runtime version should match the design time version used with VS.

    Having said all of that, reports designed in Crystal 2016 should run with the 2008 SDK as long as they don't depend on newer features (there aren't many) or data drivers.

    -Dell

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 12, 2020 at 12:43 PM

    You need to recompile your application to use SP 27.

    All info is here:

    https://wiki.scn.sap.com/wiki/display/BOBJ/Crystal+Reports%2C+Developer+for+Visual+Studio+Downloads

    SP 27 now places the CR assemblies here:

    C:\Windows\Microsoft.NET\assembly\GAC_MSIL

    Download WIKI has a link to the Licensing PDF.

    Don

    Add a comment
    10|10000 characters needed characters exceeded

    • Thanks all for your quick response!!

      I installed Crystal 2016 SP 27 and recompiled my application with the same. This time assemblies references was pointed to C:\Windows\Microsoft.NET\assembly\GAC_MSIL and I am glad to say that it worked on my development environment with Windows 2016/.NET 4.0.

      When I deployed it on another fresh Windows 2016/.NET 4.0 machine then it didn't worked on that machine. It is failing and giving me below error:

      Error in File fulaudit 7924_8728_{A0FA78DC-1E9D-4ECC-9948-AA7A5B3CD232}.rpt: Error in formula FieldValues1: 'Dim iRV as Number^M' A number, currency amount, boolean, date, time, date-time, or string is expected here. Details: errorKind.

      I tried to find out the root cause of it and found that Crystal 2016 (runtime SP 27) is unable to call u2l*.dll functions. I developed that u2l*.dll and it worked perfectly fine with Crystal 2008 but does not work with Crystal 2016 (runtime SP 27). When I use the same DLL with Crystal 2008, it works perfectly.

      I could figure out that crystal 2016 (runtime SP 27) is able to load u2l*.dll and successfully calls DllMain function in it but does not able call another exported c-style functions.

      Then I used Crystal 2016 designer and tried to print the report from there itself and that also giving me same error message.Also all the exported u2l*.dll functions are not visible under "Additional function" in Crystal 2016. Same was visible in Crystal 2008.

      I am struggling to fine out the root cause of not able to make a call for those exported DLL function (u2l*.dll) while Crystal 2008 are able to call those function without any issue.

      I enabled Crystal logs using CRlogger and found following error messages:

      ==============================================

      2020-7-23-13-53-3210844..\cserrinf.cpp523Error 31682 (..\src\ufldll.cpp, 427): : C:\Windows\crystal\U2LReports.dll1

      2020-7-23-13-53-3210844..\cserrinf.cpp523Error 14721 (..\csdll.cpp, 150): : C:\Windows\crystal\U2LReports.dll1

      2020-7-23-13-53-3210844..\cserrinf.cpp523Error 14721 (..\src\ufldll.cpp, 240): : C:\Windows\crystal\U2LReports.dll1

      ==============================================

      Please help me to figure out this issue with Crystal 2016.

      Thanks

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.