Skip to Content

The API dev portal application cannot be subscribed to product on SAP Web IDE

Hello Experts.

I was trying to create a project template on SAP web IDE. The main intention is to consume the application from SAP API developers portal.

I have set up the destinations to both developers portal and API portal on SAP hana cockpit

destination-to-developers-portal.png

destination-to-api-portal.png

The roles are present as mentioned in the below link

https://help.sap.com/viewer/66d066d903c2473f81ec33acfe2ccdb4/Cloud/en-US/a1fd1fd03a1048c988aff3ea139fbaad.html

Whenever I try to create a new SAP Fiori Master-Detail Application. I get an error when I try to assign the product through Service catalog.

sap-web-ide-error.png

Can some one please let me know where I am going wrong

Thanks for your time

Appreciate your support

Regards

Advit

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Posted on May 25, 2020 at 12:56 PM

    Hi Advit,

    Did you get solution for this?. I am also getting the same issue and no help from anywhere. If you got solution, then please help me, it will be very appreciable.

    Many Thanks / Himanshu Gupta

    hemugupta.1989@gmail.com

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 06, 2020 at 07:37 AM

    Hello Matteo,

    Thanks!! for update, this will help me in saving number of hours otherwise on weekend I would spent time in troubleshooting. Let me wait for few number of days, then will come back to my POC.

    Many Thanks / Himanshu Gupta

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 30, 2020 at 11:24 PM

    Try going into the authorizations section and giving yourself the WebIDE authorizations administrator and developer. That worked for me.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 01, 2020 at 06:30 PM

    I am struggling with this issue. Please let me know if its solution is found.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Raj,

      This was a bug with a post-update incompatibility for the two services. Please ensure you are using the latest version of WebIDE when trying to connect. This should be fixed or getting fixed in coming days. If you are still struggling please open a ticket.

      Regards,
      Elijah

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.