Skip to Content
May 02, 2020 at 03:09 PM

FTP from SAP Data Services not working - how to trace or debug ?


Hi, I have a job running on SAP Data Services 14.2.8 which successfully sends files via FTP to an AIX server running FreeFTPd software. I now need to send a copy of the files to a different AIX server running fileZilla. Despite lots of checks from system programmers at both ends of the connection (NAT, firewall, ports, file/directory auths, etc), the ftp to the new server keeps failing with a timeout after the number of retries specified in the job. The same job is used to send the files to the 2 different ftp servers (2 different data flows in the same job), the only difference is the file location specified for the ftp destination.

Our system programmer has signed onto the DS job server (I don't have access) and says the FTP does NOT work from there either ... but I don't know what he tried to do.

I can ftp onto both servers with no problem via Windows CMD window or a variety of our other linux servers, and I can create a file on the new destination via these sessions. I can also turn on passive mode (quote PASV) and get an error switching to active mode (quote PORT) on BOTH destination servers, so they seem equal from that perspective.

I've tried using a DS job script to run the "standard" FTP program ... but it returns with "ftp command unknown", so maybe Data Services uses its own ftp program ? Can it be called directly, maybe it has parms for trace/debug ?

I can't find any reference to an option to trace or debug an FTP in Data Services, does one exist ?

Anyone have any ideas ? Thanks in advance !